Baclays planned maintenance

Incident Report for Volume

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 15:10 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 21, 2026 - 06:40 UTC

Monitoring

Planned maintenance
Posted Mar 21, 2026 - 06:38 UTC

Investigating

Volume would like to advise you of the upcoming maintenance period that will temporarily affect Barclays services. Please find the details below:

Institution: Barclays Corporate

Maintenance Date: 21/03/2026

Maintenance Time: 03:00 - 23:30 GMT

Impact Level: Service Maintenance
Posted Mar 21, 2026 - 03:00 UTC
This incident affected: Institutions (Barclays Personal).