Delay in Receiving SETTLED Notifications

Incident Report for Volume

Resolved

This incident has been resolved.
Posted Nov 05, 2025 - 18:09 UTC

Investigating

We are aware of the issues with SETTLED payment status updates and are actively working to resolve them as quickly as possible.
Posted Nov 05, 2025 - 16:20 UTC