Lloyds Banking Group Service Disruption

Incident Report for Volume

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 20:13 UTC

Identified

We are aware of an intermittent service disruption affecting Lloyds Group banks. The issue has been identified as originating on their side and has been escalated to them. We will provide further updates as more information becomes available.
Posted Sep 04, 2025 - 17:59 UTC
This incident affected: Institutions (Bank of Scotland, Halifax, Lloyds).