German banks payment service disruption

Incident Report for Volume

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 15:37 UTC

Update

Service operational - monitoring
Posted Mar 18, 2026 - 15:37 UTC

Investigating

Our provider is investigating problem
Posted Mar 18, 2026 - 14:42 UTC
This incident affected: Institutions (German Banks).