Elevated payment creation error rate for some institutions

Incident Report for Volume

Resolved

This incident has been resolved.
Posted Sep 26, 2026 - 10:35 UTC

Identified

We have reported this to the upstream institutions
Posted Sep 26, 2026 - 08:18 UTC
This incident affected: Institutions (Halifax, Lloyds, Royal Bank of Scotland).