Virtual Account Services Disruption

Incident Report for Volume

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 15:14 UTC

Investigating

We are aware of the issues affecting payment SETTLED status and payout processing. Our team is actively working with the banking partner to resolve these matters as quickly as possible and minimize any disruption.
Posted Mar 23, 2026 - 15:09 UTC
This incident affected: Virtual Account (Pay-ins).