Degraded Performance of Virtual Accounts

Incident Report for Volume

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 10:53 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2026 - 10:53 UTC

Investigating

We observed degraded performance, and we are working with our providers to fix it.
Posted Apr 30, 2026 - 10:23 UTC
This incident affected: Virtual Account (Pay-ins, Pay-outs) and Merchant Dashboard.